Maps SDK cant work in android

I try to use your sdk and cant do it, all time a got
the same error :

4 files found with path ‘lib/arm64-v8a/libc++_shared.so’ from inputs:

  • C:\Users\Renlov.gradle\caches\transforms-3\3205db8f5b6b4922ab5a14b44dfe507c\transformed\native-framework-http-10.0.0\jni\arm64-v8a\libc++_shared.so
  • C:\Users\Renlov.gradle\caches\transforms-3\7d2f85ad52407f7d7e3df74667797768\transformed\native-framework-logging-10.0.0\jni\arm64-v8a\libc++_shared.so
  • C:\Users\Renlov.gradle\caches\transforms-3\c86dfed35fdae291af8fbb7586a583a2\transformed\native-framework-memchannel-10.0.0\jni\arm64-v8a\libc++_shared.so
  • C:\Users\Renlov.gradle\caches\transforms-3\87e88a5d0a9a56af72d5538a4b17201c\transformed\native-mapdisplay-engine-10.0.0\jni\arm64-v8a\libc++_shared.so
    If you are using jniLibs and CMake IMPORTED targets, see
    Android Gradle plugin release notes  |  Android Developers

but i added all dependencies

is settings :
dependencyResolutionManagement {
repositoriesMode.set(RepositoriesMode.FAIL_ON_PROJECT_REPOS)
repositories {
google()
mavenCentral()
maven {
url = uri(“JFrog”)
}
}
}
in build.gradle(app) :
packagingOptions {
pickFirst “lib/**/libc++_shared.so”
}
in build.gradle(module) :
implementation “com.tomtom.sdk:maps-display:0.3.303”

Hi,
After a quick investigation of your code, it looks good.
This part should fix your issue:

in build.gradle(app) :
packagingOptions {
    pickFirst "lib/**/libc++_shared.so"
}

If you can, please, recheck your code and try to rebuild your project.

If it doesn’t help, please, upload your whole code somewhere where we can work with it.
E.G., GitHub.

2 Likes

Yeap, sorry, i have multimodule project and forgot added in another build.gradle this code :
packagingOptions {
pickFirst “lib/**/libc++_shared.so”
}

if somebody will have this trouble - add in another module packagingOptions

2 Likes