Failed to resolve for all the packs

Im trying to migrate to your new dependencies but they dont work.

in settings file

dependencyResolutionManagement {
    repositoriesMode.set(RepositoriesMode.FAIL_ON_PROJECT_REPOS)
    repositories {
        google()
        mavenCentral()
        maven {
            url = uri("https://repositories.tomtom.com/artifactory/maven")
        }
    }
}

and im build file

implementation 'com.tomtom.sdk:maps-display:0.3.303'
implementation 'com.tomtom.sdk:location-android:0.3.303'
implementation 'com.tomtom.sdk:search-client-online:0.3.303'
implementation 'com.tomtom.sdk:routing-client-online:0.3.303'

i get Failed to resolve: com.tomtom.sdk:maps-display:0.3.303 and the same for all of them.

Hi,
Can you try change ’ with " like in our example:

dependencies {
    implementation "com.tomtom.sdk:maps-display:0.3.303"
}

You can see this in here: Quickstart | TomTom SDK for Android

I just had to restart my computer. Don’t know why cos i tried clearing cache and restarting android studio before but it didn’t work. The quotes don’t matter.

1 Like

Good to know. I’m glad it works now.