Can't understand toturials

Hi!
I just started learning android programming and I want to make a map app.
But i really can’t understand your toturials.It’s not really step by step and when i put codes in my app it make errors. even your sample app code have so many errors and i can’t run it(screenshot).
please help me I dont know what should I do.

Downloads | Maps SDK for Android | TomTom Developer Portal. You need to implement depedencies.

//library required to display map
implementation("com.tomtom.online:sdk-maps:2.4807")

//library required for search
implementation("com.tomtom.online:sdk-search:2.4807")

//library required for routing
implementation("com.tomtom.online:sdk-routing:2.4807")

//library required for traffic
implementation("com.tomtom.online:sdk-traffic:2.4807")

//library required for geofencing
implementation("com.tomtom.online:sdk-geofencing:2.4807")

//extention library for map custom style and ui support
implementation("com.tomtom.online:sdk-maps-ui-extensions:2.4807")

//extention library for rx-java2
implementation("com.tomtom.online:sdk-maps-rx-extensions:2.4807")

//extention library for kotlin support
implementation("com.tomtom.online:sdk-maps-ktx-extensions:2.4807")

//extention library for displaying static map
implementation("com.tomtom.online:sdk-maps-static-image:2.4807")

//extention library for driving features
implementation("com.tomtom.online:sdk-maps-driving-extensions:2.4807")

Hi,
If you want to follow the tutorial step by step look at Search along a route tutorial. On the other hand, the Time to leave tutorial contains only code related to TomTom SDK.

I did and still have errors

I did all how you don’t get errors?
I have worked with other SDKs before, they all need to import their library, but I have not seen anything like this on this site.

Have you tried to download and run the code from the tutorial?

Check your project and module build.gradle if you did everything from the Preriquested section of Search along a route tutorial.

why i have 120 errors in main activity?!
whats wrong??

You can try to clean build or File → Invalidate Caches / Restart in Android Studio, if it is not working
can you show both project and module build Gradle?

I imported this code: GitHub - tomtom-international/tomtom-use-case-search-along-a-route-android: Search along a route e
I tried Invalidate Caches / Restart and now i have 170 errors XD WTF!
what is your gradle version?

I’ve just checked it with the newest gradle 7.0.1 and it is working.
Did you add this repository in project build.gradle?

maven {
        url "https://maven.tomtom.com:8443/nexus/content/repositories/releases/"
}
1 Like