400 Bad Request on one specific address

The following address can not be used as destination in the routing api.

Bosboomstraat 1
3582 KE Utrecht
(in the Netherlands)
This address has (according to the BAG) the coordinates: 52.08156123 , 5.13827178

The call to
https://api.tomtom.com/routing/1/calculateRoute/52.07157633,5.09082824:52.08156123,5.13827178?key=<my_key>
results in a “HTTP/1.1 400 Bad Request” error: Engine error while executing route request: NO_ROUTE_FOUND

This address as origin and all other addresses are no problem. It is just this address as destination.

It looks like a data problem. Can you report this via Map Share reporter?

1 Like

I did. The status is now ‘accepted’. The problem is not (yet) solved.

The final status should be “fixed”. So we need to wait till it gets this status + some time to propagate new data.

The status is now “fixed”. Waiting for the data to propagate…

Still waiting for the data to propagate…

fixed (for the second time). Still waiting for the data to propagate.

Still waiting for the data to propagate. No response on support ticket.

Still waiting for the data to propagate. Still no response on support ticket.

I have identified your report and I see that it was partially fixed. I created an internal ticket to fix this issue. I’ll let you know once I have more info.

Can you check now? I just checked at MyDrive and it looks that it is now possible to calculate a route to this address.

I’m sorry. No route found. Can you check this link?
https://api.tomtom.com/routing/1/calculateRoute/52.07157633,5.09082824:52.08156123,5.13827178?key=<my_key>
Of course, with your api-key.

It seems to be a difficult problem, taking months to solve…

Still no solution … after such a long time …

Same issue… no solution…

Same address, or a different one ?

In our data there is an unrestricted road on the east side, that can be accessed thru roads that are available only for ambulances, etc.
Can you confirm that?
So there are two options:

  • we need to set this unrestricted road as available only for ambulances
    or
  • we need to remove restrictions from surrounding roads

You are probably right. I don’t know the situation. I just know that the official Dutch BAG gives these coordinates with this address and TomTom can’t use these coordinates as destination. There is no problem using these coordinates as origin.

It can be set as a starting point because there is a one way route that is not restricted.

I know it took a lot of time, but it is finally solved in current maps.